Re: {Collins} 75S-3 PROBLEMS



Does the S meter move when you tune through the calibrator signal? 

Does the S meter swing nearly fully to the right when you turn the RF gain pot fully CCW?

Does the speaker make a loud pop when you pull out the audio output tube with the receiver power? It should.

Do you hear crackles when you rotate the band switch with AF gain fully CW? You should.

Does any audible change take place when you change filter positions with the AF gain fully CW?

Once you answer these questions, I can give you some good guidance.

Gary

Sent from my iPad

> On Dec 29, 2014, at 9:36 PM, MBenzguy <mbenzguy@xxxxxxxxxxx> wrote:
> 
> Hello list
> 
> I put a good working 75S-3 in storage about one year ago. It worked 100% and had no issues.
> Put it inline with my 32S1 this morning and it lights up but no audio/ receive.
> Speaker / headphone no audio ( not even a hiss)
> Calibrator works as I can faintly hear it ringing in one of the tubes, but not speaker.
> Meter is pulled backward below 0 on meter scale.
> Preselector seems to work as it varies level of the calibrator on all bands
> RF gain also will adjust level of calibrator like one would expect.
> Works the same whether in STBY or OPR
> Nothing smoked or popped when I turned it one....it just doesn't want to receive.
> I don't have any spare tubes to substitute ( shame on me) so not sure where to start looking
> Any thoughts?
> 
> Thanks
> 
> Paul AD3G
> *** You are subscribed to Collins as dukeshifi@xxxxxxxxxxx. If you wish to unsubscribe, or modify your preferences please visit http://mailman.listserve.com/listmanager/listinfo/collins ***



This archive was generated by a fusion of Pipermail (Mailman edition) and MHonArc.